Matura 2017 (maj). Zadanie 5. Kemping

Matura 2017 (maj). Zadanie 5. Kemping

Polskie Towarzystwo Podróżnicze prowadzi ośrodek wypoczynkowy „Cichy Kącik”. W ośrodku znajdują się domki kempingowe następujących typów: 2-, 3-, 4-, 5- i 6-osobowe. Towarzystwo rozważa zmianę sposobu naliczania opłat i w tym celu planuje analizę działalności ośrodka wypoczynkowego w roku 2014. W pliku wynajem.txt zapisana jest historia wynajmu z 2014 roku.

W każdym wierszu zapisano: datę wynajęcia domku (data_przyjazdu), datę opuszczenia domku (data_wyjazdu), koszt zużytej energii (energia), koszt zużytej wody (woda) oraz wielkość wynajętego domku (typ). Daty w pliku są podawane w formacie: RRRR-MM-DD.

Pierwszy wiersz pliku jest wierszem nagłówkowym.

Poszczególne dane w każdym wierszu rozdzielone są znakami tabulacji.

Przykład:

data_przyjazdu data_wyjazdu energia woda typ
014-01-02 2014-01-11 39,35 1,04 5
014-01-02 2014-01-23 3,79 0,10 6
014-01-02 2014-01-14 3,88 0,10 6
014-01-02 2014-01-22 6,43 0,17 5

Wykorzystaj dane zawarte w pliku wynajem.txt oraz dostępne narzędzia informatyczne i wykonaj poniższe zadania. Odpowiedzi do poszczególnych zadań zapisz w pliku tekstowym o nazwie wyniki5.txt (z wyjątkiem wykresu w zadaniu 4). Odpowiedź do każdego zadania poprzedź numerem oznaczającym to zadanie.

Dane do pobrania.

Plik z danymi utworzony w programie MS Excel 2007.

Pobranie danych do programu:

Krok 1.

Krok 2.

Krok 3.

Krok 4.

Krok 5.

Zadanie 1.

Podaj, jakiego typu domki były wynajmowane najwięcej razy.

Komentarz:

Należy policzyć każdy typ domu ile razy był wynajmowany. Występują tylko typy: 2, 3, 4, 5, 6. Wykonam to za pomocą funkcji (licz.jezeli):

=LICZ.JEŻELI($E$2:$E$1001;H3)

Rozwiązanie:

Odpowiedź:

Najczęściej wynajmowanym typem domku był typ 2, został wynajęty 204 razy.

Zadanie 2.

Dla każdego typu domków oblicz łączną liczbę dób, przez które te domki były wynajmowane.

Przykład:

data_przyjazdu data_wyjazdu energia woda typ
014-01-02 2014-01-11 39,35 1,04 5
014-01-02 2014-01-23 3,79 0,10 6
014-01-02 2014-01-14 3,88 0,10 6
014-01-02 2014-01-22 6,43 0,17 5

Domki typu 5 były wynajmowane łącznie przez 29 dób, domki typu 6 były wynajmowane łącznie przez 33 doby.

Komentarz:

Pierwsza część zadania polega na obliczeniu ile dni każdy pokój był wynajmowany. Wykonać to można na zasadzie odejmowania pamiętając, że data to liczba (odejmujemy datę młodszą od starszej).

=B2-A2

Kolejna część rozwiązania zadania polega na wykorzystaniu funkcji suma.jeżeli. Funkcja ta sumuje ilość dni każdego typu dnia.

=SUMA.JEŻELI($E$2:$E$1001;I4;$F$2:$F$1001) 

Rozwiązanie:

 

 

Zadanie 3.

Klient wynajmujący domek obowiązany jest uiszczać opłatę w wysokości czynszu oraz opłatę za zużyte media (energia elektryczna i woda). Czynsz uzależniony jest od wielkości domku oraz od czasu, na jaki wynajęto domek. Przyjęto, że:

czynsz najmu = 10 zł * liczba osób w domku (typ) * liczba dób wynajmu

Przykład:

Domek 5-osobowy był wynajęty od 1 do 10 stycznia 2014 (czyli na 9 dób). Zużyto energię elektryczną za kwotę 39,35 zł oraz wodę za 1,04 zł. Czynsz wynosi: 10 zł*5 osób*9 dób = 450 zł. Opłata za wynajem zatem wyniesie: 450 zł + 39,35 zł+1,04 zł = 490,39 zł

Utwórz zestawienie zawierające dla każdego typu domku łączną sumę opłat za wynajęcie domków tego typu. Zestawienie posortuj nierosnąco ze względu na kwotę opłat.

Komentarz:

Dodajemy kolejną kolumnę w której obliczamy opłatę za wynajem w następujący sposób (funkcja):

=E2*F2*10+C2+D2

Obliczenie sumy łącznej dla każdego typu doku wykonujemy analogicznie jak przy obliczeniu ilości dni w zadaniu 2, za pomocą funkcji:

=SUMA.JEŻELI($E$2:$E$1001;J21;$G$2:$G$1001)

W tabeli obliczamy sumę opłat za każdy typ domku, ale należy jeszcze te wartości posortować w sposób Z-A.

Rozwiązanie:

Zadanie 4.

Utwórz zestawienie zawierające łączne koszty mediów (zużycie energii i wody) w poszczególnych miesiącach. Sporządź wykres kolumnowy ilustrujący otrzymane zestawienie. Pamiętaj o prawidłowym i czytelnym opisie wykresu.

Uwaga: każdy wynajem domku przyporządkuj do miesiąca odpowiadającego dacie przyjazdu (data_przyjazdu).

Komentarz:

W pierwszej części rozwiązywania tego zadania należy dodać wartości kwot za media, tj. zużycie energii i wody w kolumnie H. To zostało wykonane za pomocą funkcji suma:

=SUMA(C2:D2)

W kolumnie I wybrałem nr miesiąca, w którym został wynajęty domek za pomocą funkcji:

=MIESIĄC(A2)

W dalszej części należy wykonać sumowanie wartości z warunkiem przypisania do poszczególnych miesięcy wynajęcia domku. Funkcja ta wygląda następująco:

=SUMA.JEŻELI($I$2:$I$1001;L31;$H$2:$H$1001)

Po wykonaniu tej czynności zostało wykonać wykres z danych znajdujących się w nowo utworzonej tabeli. Wykres w arkuszu kalkulacyjnym MS Excel wstawia się poprzez menu wstaw, wybierając wykres kolumnowy.

Rozwiązanie:

PLIK Z PRZYKŁADOWYM ROZWIĄZANYM ZADANIA.

Leave a Reply

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *

You may use these HTML tags and attributes:

<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>